[Esd-l] Red Hat 9...

Tom Golson tgolson at co.brazos.tx.us
Sat Jul 26 08:29:49 PDT 2003

Hi Brad,
	I ran into the same problems when migrating to a new server with a
fresh RH9 install.  I went out and found the most recent RH RPM for
metamail (metamail-2.7-28), installed it and the mail sanitizer is
working great.  I seem to recall there was some sort of conflict, but
can't be sure.  If there was, removing the conflicting package doesn't
seem to have caused any problems.
	Good luck!

--Tom Golson

On Sat, 2003-07-19 at 19:37, Brad wrote:
> I have just replaced a Red Hat 7.3 mail server with new hardware and Red Hat 
> 9. I have managed to get everything working properly except the Sanitizer. I 
> have managed to get it working without the MS Office macro scanning, and 
> according to the Sanitizer home page:
> "If you wish to scan attachments for Office macros, you must have mimencode 
> (which is a part of the metamail package) and mktemp (from OpenBSD) 
> installed."
> mktemp comes with Red Hat 9 and so I have searched for an RPM for metamaiil 
> but have only been able to find a Red Hat 7.3 version. I have downloaded the 
> 7.3 source RPM and tried to build a v9 RPM from it, but it fails with:
> make[1]: cc: Command not found
> make[1]: *** [metamail.o] Error 127
> make[1]: Leaving directory `/usr/src/redhat/BUILD/mm2.7/src/metamail'
> make: *** [basics] Error 2
> error: Bad exit status from /var/tmp/rpm-tmp.35048 (%build)
> I have then downloaded the file listed on the Sanitizer page:
> http://www.impsec.org/email-tools/metamail-2.7-RH.tar.gz
> and followed the instructions to build it:
> # make
> (cd metamail ; make  CONFIGDIR=../.  CFLAGS="-g -I.   " CC="cc"  LDLIBS="")
> make[1]: Entering directory `/tmp/metamail/SOURCES/mm2.7/src/metamail'
> rm -f metamail.o
> cc -c  -I../. -g -I.    metamail.c
> make[1]: cc: Command not found
> make[1]: *** [metamail.o] Error 127
> make[1]: Leaving directory `/tmp/metamail/SOURCES/mm2.7/src/metamail'
> make: *** [basics] Error 2
> I'm not sure what "cc" is but I suspect that it may have something to do with 
> C++: I am not a develper.
> I have then gone to http://bmrc.berkeley.edu/~trey/emacs/metamail.html and 
> downloaded their release of metamail and only achieved the same results.
> Can anyone offer any help re: getting mimencode for Red Hat 9?
> Regards,
> Brad
> _______________________________________________
> Esd-l mailing list
> Esd-l at spconnect.com
> http://www.spconnect.com/mailman/listinfo/esd-l

More information about the esd-l mailing list