[Esd-l] Red Hat 9...

Simon Matthews simon at paxonet.com
Sat Jul 19 22:47:16 PDT 2003

On Sun, 20 Jul 2003, Brad wrote:

> Hi again John. Thanks again for your input.
> gcc was not installed and so I attempted to install it, only to be met with 
> dependency requirements. When I tried to install those as well, I had more 
> denendencies. So I tried to install those and they required even more 
> dependencies: kernel-headers -  which is not available for Red Hat 9.

For RH7.3, it is called "glibc-kernheaders". I don't have a RH9 system to
check if they used the same name there (I'm moving my servers to Gentoo,
which handles dependencies automatically and doesn't require a major
update every year).

> Hmm... what is that term? "Dependency Hell"?

Yup! But once you figure it out, everything is OK. If you ever do a 
re-install, select the option for development system in the RH install. 

> I bit the bullet and just installed gcc by itself. I then ran the RPM building 
> utility and it got some way into it before:

Always dangerous on RH systems -- it is likely there are some required 
files still missing. 


More information about the esd-l mailing list